
 

 

Microsoft Excel 2007 
Intermediate Level 
 

  C
h

e
lte

n
h

a
m

 C
o

u
rse

w
a
re

 –
 w

w
w

.cctg
lo

b
a
l.co

m
 

SAMPLE



Excel 2007 Intermediate - Page 2 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

© 1995-2010 Cheltenham Courseware Pty. Ltd.  
 
All trademarks acknowledged. E&OE. 
 
No part of this document may be copied without written permission from Cheltenham Courseware unless 
produced under the terms of a courseware site license agreement with Cheltenham Courseware. 
 
All reasonable precautions have been taken in the preparation of this document, including both technical and 
non-technical proof ing. Cheltenham Courseware and all staff assume no responsibility f or any errors or 
omissions. No warranties are made, expressed or implied with regard to these notes. Cheltenham Courseware 
shall not be responsible f or any direct, incidental or consequential damages arising from the use of any material 
contained in this document. If you find any errors in these training modules, please inform Cheltenham 
Courseware. Whilst every effort is made to eradicate ty ping or technical mistakes, we apologise f or any errors 
y ou may detect. All courses are updated on a regular basis, so your feedback is both valued by us and will help 
us to maintain the highest possible standards. 
 
Sample versions of courseware from Cheltenham Courseware 
(Normally supplied in Adobe Acrobat format): If the version of courseware that you are v iewing is marked as NOT 
FOR TRAINING, SAMPLE, or similar, then it cannot be used as part of a training course, and is made available 
purely f or content and style review. This is to giv e y ou the opportunity to prev iew our courseware, prior to making 
a purchasing decision. Sample v ersions may not be re-sold to a third party. 
 
For current license information 
This document may only be used under the terms of the license agreement f rom Cheltenham Courseware. 
Cheltenham Courseware reserves the right to alter the licensing conditions at any time, without prior notice. 
Please see the site license agreement available at:  www.cheltenhamcourseware.com.au/agreement 
 
Contact Information 
 
Australia / Asia Pacific / Europe (ex. UK) / Rest of the World 
Email: info@cheltenhamcourseware.com.au 
Web: www.cheltenhamcourseware.com.au 
 
USA / Canada 
Email: info@cheltenhamcourseware.com 
Web: www.cheltenhamcourseware.com 
 
UK  
Email: info@cctglobal.com 
Web: www.cctglobal.com 
 

 
.

SAMPLE



Excel 2007 Intermediate - Page 3 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

 

MANIPULATING DATA & NA MED RANGES ........................................................................... 5 

PASTE SPECIAL TECHNIQUES................................................................................................... 5 
Paste Special ..................................................................................................................... 5 
Transposing data ............................................................................................................... 6 

IMPORTING A TEXT FILE AND DELIMIT BY COMMA, SPACE OR TAB............................................... 7 
Importing text and delimiting by space, comma or tab...................................................... 7 

NAMED RANGES......................................................................................................................10 
What does naming a cell range mean? ............................................................................10 
Rules for naming cells and ranges ...................................................................................10 
Naming cell range(s) in a worksheet ................................................................................11 
Named ranges within formulas .........................................................................................11 
Navigating through workbooks using named ranges .......................................................12 
Creating named ranges automatically based on cell values............................................12 
Deleting named cells/ranges ............................................................................................13 

SUB-TOTALING........................................................................................................................13 
Creating subtotals.............................................................................................................14 
Removing subtotals ..........................................................................................................15 

TEMPLATES .............................................................................................................................16 

Using templates ................................................................................................................16 
Creating templates............................................................................................................17 
Opening and editing templates.........................................................................................18 

FORMATTING & DISPLAY TECHNIQUES .............................................................................20 

CELL STYLES ..........................................................................................................................20 
Formatting tables ..............................................................................................................20 

TABLE STYLES ........................................................................................................................21 
Formatting tables using table styles .................................................................................21 

CONDITIONAL FORMATTING.....................................................................................................21 
Formatting cell ranges using conditional formatting.........................................................22 

CUSTOM NUMBER FORMATS ....................................................................................................23 
Creating custom number formats .....................................................................................23 

FREEZING ROW AND COLUMN TITLES.......................................................................................25 
Freezing the top row .........................................................................................................25 
Freezing the first column...................................................................................................26 
Freezing the top row and the first column at the same time ............................................27 

HIDING AND UN-HIDING ROWS AND COLUMNS ..........................................................................27 
Hiding and un-hiding rows ................................................................................................27 
Hiding and un-hiding columns ..........................................................................................29 

HIDING / UN-HIDING WORKSHEETS...........................................................................................29 
Hiding and un-hiding worksheets .....................................................................................29 

SORTING AND QUERY ING DATA ..........................................................................................32 

SORTING DATA BY MULTIPLE COLUMNS....................................................................................32 
Sorting internal Excel databases......................................................................................32 

CUSTOM SORTS ......................................................................................................................35 
Custom sort options..........................................................................................................35 

USING AUTOFILTER ................................................................................................................37 
Using AutoFilter to query data ..........................................................................................37 
Multiple queries.................................................................................................................39 
Removing filters ................................................................................................................40 

SAMPLE



Excel 2007 Intermediate - Page 4 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

Top 10 AutoFilter...............................................................................................................40 
USING ADVANCED QUERY / FILTER OPTIONS ............................................................................42 

Filtering unique records ....................................................................................................42 
Advanced Filter .................................................................................................................43 

LINKING & CONSOLIDATING DATA ......................................................................................46 

LINKING DATA OR A CHART WITHIN A WORKSHEET....................................................................46 
Linking individual cells within a worksheet .......................................................................46 
Linking charts to data within a worksheet.........................................................................46 

LINKING DATA OR A CHART BETWEEN WORKSHEETS [WITHIN A WORKBOOK].............................48 
Linking a cell range on one worksheet to another worksheet (within the same workbook)
............................................................................................................................... ............48 
Linking data on one worksheet to a chart in another worksheet (within the same 
workbook)..........................................................................................................................49 

LINKING DATA OR A CHART BETWEEN SPREADSHEETS [WORKBOOKS] ......................................51 
Linking data from one workbook to another .....................................................................51 
Linking a chart from one workbook to another .................................................................52 

LINKING DATA OR A CHART INTO A WORD PROCESSING DOCUMENT..........................................53 
Copying data from Excel into a Word document..............................................................53 
Linking data from Excel into a Word document................................................................53 
Copying a chart from Excel into a Word document..........................................................54 
Linking a chart from Excel into a Word document............................................................55 

CONSOLIDATING DATA IN ADJACENT WORKSHEETS USING A 3D SUM FUNCTION .......................56 
Consolidating data over several worksheets or worksheet pages...................................56 

CHARTS FORMATTING TECHNIQUES .................................................................................58 

Changing the angle of pie chart slices..............................................................................58 
Formatting the chart axis fonts .........................................................................................59 
Formatting the chart axis scales.......................................................................................60 
Formatting the chart axis text orientation .........................................................................62 
Creating and positioning a chart title ................................................................................63 
Re-positioning a chart legend...........................................................................................64 
Re-positioning chart data labels .......................................................................................65 
Exploding the segments within a pie chart.......................................................................66 
Deleting a data series within a chart.................................................................................68 
Adding a data series to a chart.........................................................................................69 
Modifying the chart type for a defined data series ...........................................................70 
Widening the gap between columns / bars within a 2-D chart.........................................71 
Inserting an image into a 2D chart (as a background).....................................................73 
Inserting an image into a 2D chart (to format a column or bar of data)...........................76 

PROTECTION AND SECURITY ..............................................................................................78 

WORKBOOK PASSWORD PROTECTION .....................................................................................78 
Specifying a password for opening a workbook...............................................................78 
Using the “read-only recommended” option .....................................................................80 
Removing a password from an Excel workbook ..............................................................83 

PROTECTING / UN-PROTECTING A WORKSHEET WITH A PASSWORD..........................................85 
Protecting a worksheet or worksheet elements ...............................................................85 
Removing workbook protection ........................................................................................87 
Allowing selective editing of a protected worksheet.........................................................87 

 

SAMPLE



Excel 2007 Intermediate - Page 5 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

Manipulating Data & Named Ranges 
 

Paste Special Techniques 
 

Paste Special 
 Open a workbook called Paste special 01. 
 Select the cell(s) containing the data you wish to copy, in this case the range 

A2:D6. 

 Press Ctrl+C to copy the range. 
 Select the cell you want to paste the copied data into, in this case cell F2. 

 Click on the down arrow under the Paste icon (on the Home Tab). 
 

 
 
This will display a range of Paste options.  In this case select Paste Values. 
 

 
 

 You will notice that just the values are pasted, without any of the formatting that 
was applied to the original table. 
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 Save your changes and close the workbook. 
 

Transposing data 
 Open a workbook called Paste special 02. 
 Select the cell(s) containing the data you wish to copy, in this case select the 

range A2:D6. 

 Press Ctrl+C to copy the range. 
 Select the cell you want to paste the copied data into, in this case click on cell F2. 

 Click on the down arrow under the Paste icon.  
 

 
 

 Select the Transpose command.  The data should resemble the illustration 
below. 
 

 
 

 Save your changes and close the workbook. 
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Importing a text file and delimit by comma, space or tab 
 

Importing text and delimiting by space, comma or tab 
 Click on the Office Button icon (top-left of your screen) and select the Open 

command.  The Open dialog box will be displayed.  In the Files of type section 
click on the down arrow and select All Files. 
 

 
 

 Select a text file called Import text.txt.  This file is delimited by tab stops. 
 

 
 

 Click on the Open button. You will see the Text Import Wizard (Step 1 of 3) 
dialog box, as illustrated. 
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 Notice that the dialog box has two areas, the upper referring to choices you can 
make, the lower showing the data you are about to import.  The wizard looks at 
your source data and the original file format and determines whether it is 
delimited or not.  You can choose to alter this decision if you wish.  In this case 
Delimited text is automatically detected. 

 Click Next and the Text Import Wizard (Step 2 of 3) dialog box is displayed.  
The upper half of this box allows you to select the required field delimiter.  The 
default is Tab. 
 

 
 

 The delimited text is displayed at the bottom of the dialog box.  

 Click on the Next button. The Text Import Wizard (Step 3 of 3) dialog box is 
displayed. 
 SAMPLE
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 You can select the data format for each of the columns.  You can also decide 
whether you wish to import a column or not. In this case click on the Finish 
button to import the text into your spreadsheet.  The data should be neatly 
separated into columns, as illustrated below: 
 

 
 

 Save your data in Excel Workbook format. To this click on the Office Button 
and select the Save As command.  When the Save As dialog box is displayed, 
use the Save as type section of the dialog box to select Excel Workbook.  Use 
My Delimited File as the file name. 
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 Close the workbook. 
 

Named ranges 
 

What does naming a cell range mean? 
 We have seen that cells can be referred to by their location references: 

 
Examples of single cell references would include. 
C1 
AA23 
IV16 
A1 
 
Examples of referencing a range of contiguous cells would include. 
A1:A6 
B3:X3 
B16:F20 

 

 It is also possible to name cells and ranges so that they can be referred to using 
meaningful names, such as ‘sales’. 
 
It is much easier to understand a formula such as: 
=unit_price*no_of_units 
 
than a formula of the type shown below. 
=A9*B84 

 

Rules for naming cells and ranges 
 Range names normally begin with a letter or underscore character. 

 Range names must NOT contain hyphens or spaces. 

 Range names should be limited to 255 characters. 
 Bear in mind that names of 10-15 characters in length will be visible in most drop-

down menus. 
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Naming cell range(s) in a worksheet 
 Open a file called Named ranges 01. 

 We are going to name a range for the Quantity Sold.  
 Select the cell(s) to be named, in this case cell B10.  Click in the Name Box with 

the mouse and enter the name you want to give to the cell(s), in this case 
Quantity_Sold, and press Enter.  (If you see an error message, this is because 
you did not place an underscore character between the words Quantity and 
Sold): 
 

  
 

 We are now going to name a range for the Price per Item. Highlight and select 
the cell(s) to be named, in this case cell D4.  Click in the Name Box with the 
mouse and enter the name you want to give to the cell(s), in this case 
Price_per_item, and press Enter.   
 
TIP: If you see an error message, this is because you did not place an 
underscore character between the words. 
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Named ranges within formulas 
 First click on cell B13 and enter an equals symbol (=). 

 Click on cell B10 and enter a multiply symbol (*). 
 Click on cell D4 and then press the Enter key. 

 Click on cell B13 again and notice the formula in the Formula Bar.  As you can 
see this makes the formula much easier to understand: 
 

 
 

Navigating through workbooks using named ranges 
 Having defined a set of named cell ranges, click the down arrow to the right of 

the Name Box and select the named cell/range you wish to go to from the drop 
down list that appears.  Try going to both ranges that you have named. 
 

 
 

 Save your changes and close the workbook. 
 

Creating named ranges automatically based on cell values 
 Open a file called Named ranges  02. 

 Click on cell B2, which we wish to name the cell using the name Tom. 
 Click on the Formulas tab and then click on the Define Name icon.   

 

 
 
The New Name dialog box is displayed and as you can see, has automatically 
picked up the name Tom. 
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 Click on the OK button to complete the naming of the cell. 

 Repeat these actions so that cells B3:B5 are also named with the relevant 
person. 

 

Deleting named cells/ranges 
 Click on the Formulas tab and then click on the Name Manager icon. 

 

 
 

 The Name Manager dialog box is displayed 
 

 
 

 Select the name you wish to delete, in this case Nyah and then click on the 
Delete button.  A warning dialog box is displayed, click on the OK button to 
confirm the deletion. 

 Save your changes and close the workbook. 
 

Sub-totaling 
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Creating subtotals 
 Open a workbook called Subtotals. 

 First, sort the data in ascending order, using the data in the Sales Region to 
perform the sort. 

 To do this click on Data tab.  Click on cell A3 and then click on the Sort 
Ascending icon. 
 

       
 

 Click within the data in the Sales Region column. 

 Click on the Subtotal icon. 
 

 
 
This will display the Subtotal dialog box. 
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 Click on the OK button.  You will see the data subtotaled as illustrated: 
 

 
 

Removing subtotals 
 Click on the Subtotal icon and within the dialog box displayed, click on the 

Remove All button. 
 

 
 

 Reapply the subtotals once again and the close the workbook, saving your data. 
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Templates 
 

Using templates 
 Click on the Office Button and select the New command. 

 

 
 
 

 This will display the New Workbook dialog box. In this case select the Installed 
Templates command (on the left of the dialog box).  You should see the 
following displayed. 
 

 
 

 Select the Billing Statement and click on the Create button and you will see the 
following. 
 SAMPLE



Excel 2007 Intermediate - Page 17 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

 
 

 Take a little time to examine the workbook that has been created for you.  You 
can click on the various fields within the document.  You can enter values for 
billing items and totals will be calculated automatically. After a short time 
experimenting, save the workbook as My Billing Statement, and close the 
workbook. 

 If you have time take a look at some of the other installed templates. 
 

Creating templates 
 Open a workbook called Make into template.  This is a workbook not a template.  

We will now save this workbook as a template.  To do this click on the Office 
Button and click on the Save As command.  This will display the Save As dialog 
box. 

 In the File name section of the dialog box, enter the name Monthly Sales. 

 Click on the down arrow next to the Save as Type section of the dialog box and 
select Excel Template. 
 

 
 

 Click on the Save button to save the template. 
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 Close the template. 

 To use the template, click on the Office Button and then click on the New 
command.  Select the My templates option. 
 

 
 

 You will see a dialog box displaying your template file. 
 

 
 

 Click on the Monthly Sales template and then click on the OK button.  A new 
workbook will be created, based on the template. 
 
NOTE: You have not opened the template file, you have created a new 
workbook, based on the template file. 
 
You can fill in details on the workbook (just make up some data) and then save 
the workbook as My New Sales Report.  Then close the workbook. 

 

Opening and editing templates 
 Click on the Office Button, and then click on the Open command, which will 

display the Open dialog box. 
 In the Files of type section of the dialog box, select Templates. 
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 Select your template file and you can now make changes to the actual template 
file.  Add your name next to the ‘name’ field and re-save the file. 
 
NOTE: Any changes that you make to the template file will only affect new 
workbooks that are created using the template.  Any workbooks that were 
previously created based on the template will remain unaffected. 
 

 Create a new document based on your template and this time you will see that 
your name is now automatically displayed within the new workbook.  Close the 
workbook without saving your changes. 
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Formatting & Display Techniques 
 

Cell Styles 
 

Formatting tables 
 Open a workbook called Cell styles. 
 Select a cell within the data in the worksheet. 

 Click on the Home tab and from within the Styles group click on the Cell Styles 
icon. 
 

 
 

 This will display a drop down from which you can select a style to apply to the 
selected cell(s). 
 

 
 

 Experiment with applying different formatting styles to different cells.  Remember 
that you can select more than one cell at a time by keeping the Ctrl key pressed 
as you click on cells.  When you have finished experimenting save your changes 
and close the workbook. 
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Table Styles 
 

Formatting tables using table styles 
 Open a workbook called Table styles. 
 Select the table within the worksheet. 

 If necessary select the Home tab and then click on the Format as Table icon, 
within the Styles group. This will display a drop down from which you can select 
a style to apply to your table.  Experiment with applying different styles and look 
at the effect it has on your table. 
 

      
 

 An example style is shown below. 
 

 
 

 When you have finished experimenting save your changes and close your 
workbook. 

 

Conditional Formatting 
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Formatting cell ranges using conditional formatting 
 Open a file called Conditional formatting.  This workbook contains details for 

sales over a 3-month period.  We wish to highlight all sales over 50. 

 Select the range of cells to which you wish to apply conditional formatting. In this 
example, the range would be C6:E13. 
 

 
 

 Click on the Home tab and then click on the Conditional Formatting icon (within 
the Styles group).   
 

 
 
This will display a drop down list.  In this case click on Greater Than from the 
submenu displayed. 
 

 
 

 This will display the Greater Than dialog box. We wish to highlight all values over 
50 so we need to enter the number 50, as illustrated. 
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 Next, we need to set the formatting that will be displayed to highlight numbers 

over 50.  Click on the down arrow next to the with section of the dialog box.  
Pick a formatting option, such as Red Border. 
 

 
 

 When finished click on the OK button and you will see that all cells containing 
values over 50, are now formatted, as requested. 
 

 
 

 If you have time investigate some of the other conditional formatting options.  
When you have finished experimenting save your changes and close the file. 

 

Custom number formats 
 

Creating custom number formats 
 Open a workbook called Custom number formats. 

 Select cells C6 and D6, which contain the annual balance information. 
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 Right click on the selected cells and from the popup menu displayed select the 
Format Cells command, which will display a dialog box. 

 Select the Number tab. 
 From the Category section of the dialog box, select Custom. 

 Within the Type section of the dialog box, select a format code similar to that 
shown below: 
 
#,##0;[Red]-#,##0 
 

 
 

 Within the format code, change the word Red to Blue: 
 

 
 
 Click on the OK button and the negative balance for the year 2006 will be 

displayed in blue. 

 Save your changes and close the workbook. 
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Freezing row and column titles 
 

Freezing the top row 
 Open a workbook called Freeze titles. 

 In this example, we have column titles, which in this case, are the months of the 
year, and row titles, which relate to ‘stock numbers’.  The main data area displays 
the number of each stock type sold in a particular month: 
 

 
 

 If we scroll down the page we would soon see the following.  As you can see the 
column titles are no longer visible. 
 

 
 

 Click on the View tab and from within the Window group select the Freeze 
Panes icon. 
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 You will see a drop down list of options.  Click on Freeze Top Row. 
 

 
 

 Now when you scroll down the page the top row containing the column headers 
remains frozen and visible at all times. 

 

 To unfreeze the pane, click on the Freeze Panes button and select the Unfreeze 
Panes command. 
 

 
 

Freezing the first column 
 If we now scroll to the right, we will see the following.  The row titles are no longer 

visible: 
 

 
 

 To freeze the first column, click on the View tab and from within the Window 
group select the Freeze Panes icon.  Click on the Freeze First Column 
command. 
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 If we now scroll to the right, the row titles will remain visible, as illustrated: 
 

 
 

 To unfreeze the pane, click on the Freeze Panes button and select the Unfreeze 
Panes command. 

 

Freezing the top row and the first column at the same time 
 Click on cell B2 and then click on the View tab and from within the Window 

group select the Freeze Panes icon.  Click on the Freeze Panes command. 
 

 
 

 You will find that the top row and the first column have now both been frozen. 

 Save your changes and close the workbook. 
 

Hiding and un-hiding rows and columns 
 

Hiding and un-hiding rows 
 Open a file called Hide. 

 Click the row heading to select the row you wish to hide. Highlight other rows by 
pressing Ctrl while you click on each row heading.  In this case, select the row 
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relating to Carla.  Right click on the selected row and from the popup menu 
displayed select the Hide command. 
 

 
 

 The selected row is now hidden.  As you can see Carla’s details are no longer 
displayed. 
 

 
 

 To unhide the row, select the rows above and below the hidden row, and right 
click over the selected rows.  From the popup menu displayed select the Unhide 
command.  The hidden rows will now be displayed again. 
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Hiding and un-hiding columns 
 Select the column you wish to hide, in this case the column relating to Sales for 

2005. Right click over the selected column and from the popup menu displayed, 
select the Hide command. 
 

 
 

 The column will no longer be displayed, as illustrated. 
 

 
 

 To unhide the column, select the columns on either side of the hidden column 
and right click over the selected column.  From the popup menu displayed select 
the Unhide command. 
 

 Experiment a little more with hiding and un-hiding rows and columns.  When you 
are finished, save your changes and close your workbook. 

 

Hiding / un-hiding worksheets 
 

Hiding and un-hiding worksheets 
 Open a workbook called Worksheet. 

 Right click on the sheet tab to select the sheet you wish to hide, in this case 
Sheet 2.  From the popup menu displayed select the Hide command. 
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 Sheet2 will now be hidden, as illustrated. 
 

 
 

 To unhide the worksheet, right click on one of the worksheet tabs and from the 
popup menu displayed, select the Unhide command.   
 

 
 

 You will see a dialog box displayed from which you can select the hidden sheet 
you wish to unhide. 
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 Click on the OK button and the hidden sheet will now be displayed again. 
 

 
 

 Experiment with hiding another worksheet and then save your changes and close 
the workbook. 
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Sorting and Querying Data  
 

Sorting data by multiple columns 
 

Sorting internal Excel databases 
 Open a file called Sort data 01. 
 In this example, we wish to sort the data by second name, and then by first 

name.  As you can see, there are three people with the last name Gutierrez. 

 Click within the Second_name column of data: 
 

 
 

 Click on the Data tab and from within the Sort & Filter group click on the Sort 
icon. 
 

 
 

 This will display the Sort dialog box: 
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 Click on the down arrow to the right of the Sort by section of the dialog box and 
select Second_name. 
 

 
 
 

 Make sure that the A to Z option is selected within the Order section of the dialog 
box. 
 

 
 

 Click on the Add Level button. 
 

 
 
You will see a Then by section added to the dialog box. SAMPLE
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 Click on the down arrow to the right of the Then by section of the dialog box, 
and select First_Name. 
 

 
 

 Make sure that the A-Z option button is marked within the Order section of the 
dialog box. 

 Click on the OK button and the data will be sorted by second name and then by 
first name, as illustrated: 
 

 
 

 Save your changes and close the workbook. 
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Custom sorts 
 

Custom sort options 
 Open a workbook called Custom sorts.  This contains details for a small air 

travel company, operating flights to different countries that leave on specific days 
of the week.  We wish to sort the data by the days of the week, but if we do this 
alphabetically, we would get the following: 
 

 
 

 What we want is the list sorted so that we see Monday’s flights listed first, then 
Tuesday's and so on.  To do this we need to perform a custom sort. 

 Click on a cell within the Day flights Available column. 
 Click on the Data tab and from within the Sort & Filter group click on the Sort 

icon. 
 

 
 
This will display the Sort dialog box. 
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 Click on down arrow within the Sort by section of the dialog box, and select Day 
flights Available. 

 Click on down arrow within the Order section of the dialog box, and select 
Custom List. 
 

 
 

 The Custom List dialog box is displayed.  Select the option illustrated.  
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 Click on the OK button and close all open dialog boxes.  The list will then be 
sorted by weekday, as illustrated. 
 

 
 

 Save your changes and close the workbook. 
 

Using AutoFilter 
 

Using AutoFilter to query data 
 Open a workbook called Autofilter 01. 
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 Click on any cell within the list. 

 Click on the Data tab and from within the Sort & Filter group click on the Filter 
icon. 
 

 
 
The table will then look like this. 
 

 
 

 We can click on the down arrows displayed to apply filters to the data. Click on 
the down arrow at the top of the Region column, and you will see the following. 
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 De-select Select All and then select North, as illustrated, and click on the OK 
button. 
 

 
 

 You will now only see details relating to the North region. 
 

 
 

Multiple queries 
 So far, we have filtered the data to show only sales in the North region.  We can 

now add a second filter to show only sales in the North region, over a certain 
amount, say 11.   

 To do this, click on the down arrow in the Units_Sold column and select 
Number Filters.  From the submenu displayed select Greater Than. 
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 This will display the Custom Autofilter dialog box.  Enter the number 11, as 
illustrated and click on the OK button. 
 

 
 

 The data will now be displayed as illustrated below.  Only sales above 11 within 
the North region will be displayed. 
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Removing filters 
 To remove the filter re-click on the Filter icon. 

 

 
 

 Save your changes and close the workbook. 
 

Top 10 AutoFilter 
 Open a workbook called Autofilter 02. 
 Click on any cell within the list. 

 Click on the Data tab and from within the Sort & Filter group click on the Filter 
icon.  You will see drop down arrows applied to the top of each column of data. 

 Click on the down arrow in the Units_Sold column.  Click on the Number 
Filters command and from the submenu displayed select the Top 10 command. 
 

 
 

 This will display the Top 10 AutoFilter dialog box.  Type in the number 5, as 
illustrated and click on the OK button. 
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 You will see the top 5 entries listed, as illustrated: 
 

 
 

 If you wish you can sort these, by clicking on the A-Z Sort icon within the Sort & 
Filter group of the Data tab. 
 

 
 

 The data will now look like this. 
 

 
 
 

 Save your changes and close the workbook. 
 

Using advanced query / filter options 
 

Filtering unique records 
 Open a workbook called Advanced filter.  This contains a list of names with 

company ID numbers.  If you look carefully you can see a duplicate, i.e. Carla is 

SAMPLE



Excel 2007 Intermediate - Page 43 

FOR USE AT THE LICENSED SITE(S) ONLY 
 Cheltenham Courseware Pty. Ltd. 1995-2010 www.cheltenhamcourseware.com.au 

listed twice.  In this case, the list is so small that looking for duplicates is easy, 
but just imagine trying to do this for a list of thousands of names.  We wish to 
filter this list to avoid duplicates. 
 

 First click on a cell in the Name column.  Then click on the Data tab and from 
within the Sort & Filter group, click on the Advanced button. 
 

 
 

 The Advanced Filter dialog box is displayed. 
 

 
 

 Click on Unique records only, and then click on the OK button.   
 

 
 

 We will now see the list displayed without any duplicates. Carla is only listed 
once. 
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 Save your changes and close the workbook. 
 

Advanced Filter 
 Open a workbook called Advanced Filter Criteria. This workbook contains a 

simple sales list.  We wish to filter the list so only sales made by Gina to 
Germany are displayed.  So it is easier to see, we have highlighted all sales by 
Gina, who made two sales to Germany and one to South Africa. 
 

 Enter the following (i.e. "Gina" and "Germany") into the criteria area beneath the 
list: 
 

 
 

 Select a cell within the Sales Person list. 
 Click on the Data tab and from within the Sort & Filter group click on the 

Advanced button. 
 

 
 

 The Advanced Filter dialog is displayed. Excel should have automatically 
entered your list range into the List range box. 
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 We wish to sort according to the criteria in cells A25:D26, so click within the 
Criteria range box and enter $A$25:$D$26: 
 

  
 

 Click on the OK button and Excel will filter the list, showing only records that 
match your criteria. 
 

 
 

 Save your changes and close the workbook. 
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Linking & Consolidating Data 
 

Linking data or a chart within a worksheet 
 

Linking individual cells within a worksheet 
 Open a workbook called Link worksheet data.   

 
NOTE: Please be careful to open the file called Link worksheet data,  
not a file called Link workbook data. 
 

 In this worksheet, the postage and packing cost is stored in cell A3. 

 Click on cell C7 and add the following formula: =$A$3 

 Copy this formula to cells C8:C11 (by clicking on cell C7, moving the pointer the 
bottom-right of the cell, until the mouse pointer changes to the shape of a small 
cross, and then drag down to cell C11).  The worksheet should then resemble the 
illustration shown: 
 

 
 

 Click on cell A3 and change the value from 2.5 to 3.0.  This should automatically 
change the data in the Postage and packing column data.  This demonstrates 
the advantage of linking data - it saves the time it would take to change each 
value individually. 

 Save your changes and close the workbook. 
 

Linking charts to data within a worksheet 
 Open a workbook called Link worksheet chart. 

 When you select data within a worksheet and create a chart from this, by default 
the chart is automatically linked to the data.  Any changes made to the data that 
the chart was based on, will be reflected in the chart.   

 Click within the data. 

 Click on the Insert tab and from within the Charts group click on the Column 
icon. 
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 This will display a drop down list of chart options.  Click on the first 2-D chart 
option illustrated. 
 

 
 

 The chart will be displayed as illustrated. 
 

 
 

 Change the sales values for the North or South regions and the chart will 
automatically update to reflect these changes. 
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 Save your changes and close the workbook. 
 

Linking data or a chart between worksheets [within a workbook] 
 

Linking a cell range on one worksheet to another 
worksheet (within the same workbook) 
 Open a workbook called Link data between worksheets.  This workbook 

contains two page tabs.  Note that postage and packing value is stored on the 
second sheet. 

 In this example, we will link the Postage and packing value on the second 
worksheet to a cell within the first worksheet of the workbook. 

 Click on cell C4 on the first worksheet. 
 Type in the equals sign (=). 

 Click on the tab of the second worksheet (at the bottom of the workbook). 
 Click on cell A4 (in the second worksheet). 

 Press Enter and you will return to Sheet 1. 

 Re-click on cell A4 and you examine the formula within this cell: 
 

 
 

 You have linked data from one worksheet to another worksheet.  Notice the 
syntax in cell A4.  You can use the help within Excel to get more information. 
Save your changes and close the workbook 
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Linking data on one worksheet to a chart in another 
worksheet (within the same workbook) 
 Open a workbook called Link chart between worksheets. 

 
NOTE: Be careful not to open a different file called  
Link chart between workBOOKS 
 

 Click on the worksheet tab called Chart.  You should now be viewing an empty 
worksheet. 

 Click on the Insert tab and from within the Charts group click on the Column 
button.  Select the first chart within the 2-D options. 
 

 
 

 You will see an empty chart placeholder displayed within your worksheet. Right 
click on this empty chart placeholder and you will see a popup menu displayed.  
Click on the Select Data command. 
 

    
 

 This will display the Select Data Source dialog box. 
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 Click on the Data worksheet tab (bottom-left of your screen). 
 

 
 

 Select the table of data. 
 
NOTE: You may have to move the dialog box so that you can select the data. 
 

 
 

 Click on the OK button and the chart will be displayed on the second worksheet, 
using that data you selected on the first worksheet. 

 Try altering the data on the first worksheet and if you switch to the second 
worksheet, you should find that the chart has changed to reflect your changes. 

 Save and close your workbook. 
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End of the preview sample 
 
 

 
 
This sample is approximately half of the full course.  Please see the table of contents 
at the beginning of this document to see the full list of topics covered in the full 
course. 
 
To purchase the rights to use the full training manuals at your training centre please 
see our web site at:  
 

http://www.cctglobal.com 
 
A courseware licence allows you to make unlimited copies for use at your training 
centre. 
 

 
 
In addition you get HTML formatted versions of each 
course, included with our printable courseware. 
 
Invest in a complete Computer Courseware 
Library, including Windows 7 & Office 2010 
The most cost effective courseware solution for your 
IT training needs. Get ALL our courses, and all new 
courses released within 12 months. 
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