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Installing the Sample Files into the Hard Disk 
 
 

Installing the Sample Files 
 

 Use Windows Explorer to create a folder called Access XP Intermediate 
Samples, in the My Documents folder. 

 Copy the sample files for this course to the My Documents\Access XP 
Intermediate Samples folder.  If these files have been copied to your 
network server, then ask your trainer/supervisor for more information about 
how to copy these files to your PC’s hard disk. 
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Working with the Northwind Sample Database 
 
 

Installing the Northwind Database 
 

 Open Microsoft Access 2002. 
 Click the Search button on the Database toolbar. 
 In the Search text box, type Northwind. 
 Click Search. 
 If Northwind.mdb appears in the Search Results, click on the file to open 

it and proceed to the next chapter. 
 If Northwind is not found in the Search Results it will need to be installed. 
 Insert the Microsoft Office XP CD-ROM in the CD-ROM drive. 
 Double-click Setup. 

 
Note:  If your computer has autorun enabled you will be presented directly 
with the Microsoft Office XP setup screen. 
 

 Select Add or Remove Features. 
 Click Next. 
 Under Features to Install, select the Microsoft Access for Windows subtree. 
 Under Sample Databases, select Run all from My Computer. 
 Click Update. 
 Once the installer completes, click OK to finish. 
 Click the Search button on the Database toolbar. 
 In the Search text box, type Northwind. 
 Click Search. 
 When Northwind.mdb appears in the Search Results, click on the file to 

open it and proceed to the next chapter. 
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Designing Tables in Access 2002 
 
 

Establishing Relationships 
 

 With Northwind open, click OK on the Northwind Traders splash screen. 
 At the Main Switchboard, click the Display Database Window button. 
 Click the Relationships button on the Database toolbar. 
 Right-click on the relationship between the Employees and Orders tables. 
 From the pop-up menu, select Delete. 
 Click the Yes button when prompted to delete the relationship. 
 To re-create the relationship between the Employees and Orders tables, 

drag the EmployeeID field from the Employees table to the EmployeeID 
field in the Orders table. 

 Click Join Type in the Edit Relationships dialog box. 
 Select the option button labeled 2. 
 Click OK. 
 Check the Enforce Referential Integrity box. 
 Check the Cascade Update Related Fields check box. 
 Check the Cascade Delete Related Fields check box: 

 

 
 

 Click Create. 
 Click the Save button. 
 Close the Relationships window. 
 
 

Working with Indexes 
 

 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Click the Indexes button on the Table Design toolbar. 
 Type ContactName in the Index Name column. 
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 Select ContactName from the drop-down menu in the Field Name column. 
 Select Descending from the drop-down menu in the Sort Order column. 
 Select Yes from the Ignore Nulls drop-down menu in the Index 

Properties area: 
 

 
 

 Click the Close button on the Indexes title bar. 
 Click the Save button. 
 Close the table. 
 
 

Working with Data Types 
 

 Click on Tables in the Objects pane. 
 Open the Customers table in Design view. 
 Type a new field named CompanySlogan in the Field Name column. 
 Select Text from the Data Type drop-down menu. 
 In the Field Properties area, set the Field Size to 100. 
 Click the Save button. 
 Close the table. 
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Designing Queries in Access 2002 
 
 

Creating Action Queries 
 

 Click on Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close. 
 Click on the Query Type drop-down menu on the Query Design toolbar. 
 Select Update Query. 
 Select UnitPrice from the Field drop-down menu. 
 Select the Update To section of the query grid and type [UnitPrice]*2: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the update. 
 Click Yes to apply the changes. 
 Save the update query as Multiply Unit Price by Two. 
 Click OK. 
 Right-click on the Products table in the query window. 
 From the pop-up menu, select Remove Table. 
 Click the Show Table button on the Query Design toolbar. 
 Select Orders from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close 
 Click the Query Type drop-down menu on the Query Design toolbar. 
 Select Delete Query. 
 Select OrderID from the Field drop-down menu. 
 Type 10249 in the Criteria section of the query grid: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the delete. 
 Click Yes to apply the changes. 
 From the main menu, select File > Save As. 
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 Type Delete OrderID 10249. 
 Click OK. 
 Close the query window. 
 

Creating Parameter Queries 
 

 Click on Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close. 
 Select ProductID, ProductName, and SupplierID from the Field drop-

down menu. 
 In the Criteria text box under ProductName, type [Enter a Product Name]: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query. 
 Type Chai. 
 Click OK: 

 

 
 

 Save the query as Search By Product Name. 
 Click OK. 
 Close the query. 
 
 

Creating Calculated Columns in Queries 
 

 Click on  Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK. 
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 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Click Close. 
 Select ProductName and UnitPrice from the Field drop-down menu. 
 In the next field type [UnitPrice]*10: 

 

 
 

 Click the Run button on the Query Design toolbar to execute the query: 
 
Note:  Access automatically displays the calculated column as Expr1. 
 

 Save the query as UnitPrice * 10. 
 Click OK. 
 Close the query. 
 
 

Joining Tables 
 

 Click Queries in the Objects pane. 
 Click the New button to open the New Query dialog box. 
 Select Design View. 
 Click OK. 
 Select Products from the Tables tab in the Show Table dialog box. 
 Click Add. 
 Select Unit Price * 10 from the Queries tab in the Show Table dialog box. 
 Click Add. 
 Click Close. 
 Create a join between the tables by dragging and dropping the 

ProductName field from the Products table to the ProductName field in 
the Unit Price * 10 query: 
 

 
 
 For the first field, select Products.ProductName from the Field drop-down 

menu: 
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 For the second field, select Products.QuantityPerUnit from the Field drop-
down menu: 

 For the third field, select UnitPrice * 10.Expr1 from the Field drop-down 
menu: 
 

 
 

 Click the Run button on the Query Design toolbar to execute the query. 
 Save the query as Join Product and Price * 10. 
 Click OK. 
 Close the query window. 
 
 

SAMPLE



Microsoft Access XP - Intermediate Level Workbook - Page 12 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

Designing Forms in Access 2002 
 
 

Creating Data Entry Forms 
 

 Click Forms in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Products from the drop-down menu. 
 Click OK. 

 
Note:  Close the Form properties dialog box if it appears. 
 

 Drag and drop the ProductName and UnitPrice fields from the Products 
data source to the Detail area of the form: 
 

 
 

 Right-click on the ProductName control. 
 From the pop-up menu, select Properties. 
 Select the Format tab. 
 From the Special Effect drop down-menu, select Raised: 

 

 
 

 Close the dialog box. 
 Right-click in the Detail area of the form. 
 From the pop-up menu, select Page Header/Footer. 
 Click the Label control on the Toolbox toolbar. 
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Note:  From the main menu, select View > Toolbox if the Toolbox toolbar 
is not open. 
 

 Place the Label control on the page footer section of the form: 
 

 
 

 Type Product Entry Form: 
 

 
 

 Save the form as Product Entry Form. 
 Click OK. 
 Close the form. 
 
 

Working with Subforms 
 

 Open the Product Entry Form in Design view. 
 Click the Subform/Subreport button on the Toolbox toolbar: 

 

 
 

 Create a subform in the Detail area of the form: 
 

 
 

 Select the Use existing Tables and Queries option button. 
 Click Next. 
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 Select Table: Categories from the Tables/Queries drop-down menu. 
 Add the CategoryID, CategoryName and Description fields. 
 Click Next. 
 Select the Choose from a list option button. 
 Click Next. 
 Type Show Categories Subform as the name of the subform. 
 Click Finish. 
 Save the changes to the Product Entry Form. 
 Close the form. 
 
 

Creating Pop-up Forms 
 

 Open the Product Entry Form in Design view. 
 If the Form properties dialog box is not open, right-click on the main form 

area. 
 From the pop-up menu, select Properties. 
 Click the Other tab. 
 Select Yes from the Pop Up drop-down menu: 
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 Select Yes from the Modal drop-down menu: 
 

 
 

 Close the Form properties dialog box. 
 Save the changes to the Product Entry Form. 
 Close the form. 
 
 

Working with Switchboards 
 

 From the main menu, select Tools > Database Utilities > Switchboard 
Manager. 

 Click New in the Switchboard Manager dialog box. 
 Type Sample Switchboard for the name of the switchboard: 

 

 
 

 Click OK. 
 Select Sample Switchboard. 
 Click Edit. 
 Click New. 
 Type Open Product Entry Form in the Text field. 
 Select Open Form in Add Mode from the Command drop-down menu. 
 Select Product Entry Form in the Form drop-down menu: 
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 Click OK. 
 Click Close. 
 Click the Make Default button. 
 Click Close. 
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Designing Reports in Access 2002 
 
 

Working with Standard Reports 
 

 Click Reports in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Products from the drop-down menu. 
 Click OK. 
 Drag and drop the ProductName, UnitPrice, and UnitsInStock fields from 

the products data source to the Detail area of the report. 
 Cut the Product Name, Unit Price, and Units In Stock labels from the 

Detail area of the report and paste in the Page Header area of the report. 
 Rearrange the labels and controls as shown below: 

 

 
 

 Right-click in the Detail area of the report. 
 From the pop-up menu, select Report Header/Footer. 
 Click the Label control on the Toolbox toolbar. 
 Place the Label control on the Report Footer section of the report: 

 

 
 

 Type Products Report: 
 

 
 

 Right-click in the detail area of the report. 
 From the pop-up menu, select Sorting and Grouping. 
 Select UnitPrice from the Field/Expression drop-down menu. 
 Select the Descending sort order from the Sort Order drop-down menu: 
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 Close the Sorting and Grouping dialog box. 
 Save the form as Products Report. 
 Click OK. 
 Close the report. 
 
 

Working with Subreports 
 

 Click Reports in the Objects pane. 
 Click the New button. 
 Select Design View. 
 Select Categories from the drop-down menu. 
 Click OK. 
 Drag and drop the CategoryName and Description fields from the 

Categories data source to the Detail area of the report. 
 Resize the labels and controls as shown below: 

 

 
 

 Click the Subform/Subreport button on the Toolbox toolbar. 
 Create a subreport in the Detail area of the form: 
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 Select the Use existing Tables and Queries option button. 
 Click Next. 
 Select Table: Products from the Tables/Queries drop-down menu. 
 Add the ProductName field. 
 Click Next. 
 Select the Choose from a list option button: 

 

 
 

 Click Next. 
 Type Products subreport as the name of the subreport. 
 Click Finish. 
 With the main report in Design view, move and resize the Products 

subreport as shown below: 
 SAMPLE
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 Change the Report Header for the Products subreport to Products: 
 

 
 

 Right-click on the Product subreport label just above the subreport as 
shown below: 
 

 
 

 From the pop-up menu, select Cut. 
 Save the report as Categories and Products. 
 Click OK. 
 Close the report. 
 
 

Working with Report Snapshots 
 

 Click Reports in the Objects pane. 
 Select the Categories and Products report. 
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 From the main menu, select File > Export. 
 Locate your Access XP Intermediate Samples folder. 
 Select Snapshot Format from the Save as type drop-down menu: 

 

 
 

 Name the file Categories and Products Snapshot. 
 Click Export. 

 
Note:  To see a sample of this snapshot report, open Categories and Reports 
Snapshot Sample.snp in your Access XP Intermediate Samples folder. 

 
 

Developing Data Access Pages 
 

 Select Pages in the Objects pane. 
 Click the New button. 
 Select Page Wizard. 
 Select Customers from the drop-down menu. 
 Click OK. 
 Select all fields from the Available Fields list: 

 

 
 

 Click Next. 
 Select CompanyName for the grouping level: 
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 Click Next. 
 From the sort order drop-down menu, select CustomerID. 
 Set the sort order as Ascending: 

 

 
 

 Click Next. 
 Type Customers as the name for the data access page. 
 Click Finish. 
 This opens the Customers data access page in Design view. 
 Save the file as Customers.htm in your Access XP Intermediate Samples 

folder. 
 Click Save. 
 Close the Customers data access page. 

 
Note:  To see a sample of what the Customers data access page should 
look like, open the Customers Sample.htm in your Access XP 
Intermediate Samples folder. 
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Working with PivotTables and PivotCharts 
 
 

Creating Pivot Tables and Pivot Charts 
 

 Click Queries in the Objects pane. 
 Double-click the Quarterly Orders by Product query to open it in 

Datasheet view. 
 From the main menu, select View > PivotTable View. 
 From the Pivot Table Field List toolbox, drag and drop the Product Name 

field on the row fields portion of the worksheet: 
 

 
 

 Drag and drop the OrderYear field on the filter fields portion of the 
worksheet: 
 

 
 

 Drag and drop the CustomerID field on the column fields portion of the 
worksheet: 
 

 
 

 Drag and drop the Qtr 1 field on the detail fields portion of the worksheet: 
 

 
 

 Click the Product Name drop-down menu. 
 Deselect the All check box. SAMPLE
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 Check the Alice Mutton, Chai, and Chang boxes: 
 

 
 Click OK. 
 Click the CustomerID drop-down menu. 
 Deselect the All check box. 
 Check the ALFKI, BERGS, and BONAP boxes: 

 

 
 

 Click OK. 
 Save the changes. 
 From the main menu, select View > PivotChart View. 
 Drag and drop the Qtr 1, Qtr 2, Qtr 3, and Qtr 4 fields on the data fields 

portion of the worksheet: 
 

 
 

 From the main menu, select PivotChart > Chart Type. 
 Click the Type tab. 
 Change the chart type to a 3D Column chart: 
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 Save the changes. 
 Close the Quarterly Orders by Product pivot chart worksheet. 
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Importing and Exporting 
 
 

Linking to External Data Sources 
 

 Click Tables in the Objects pane. 
 Click the New button. 
 Select Link Table. 
 Click OK. 
 From the Files of type drop-down menu, select Text Files (*.txt; *.csv; 

*.tab; *.asc). 
 Locate your Access XP Intermediate Samples folder. 
 Select the Territories.txt file. 
 Click Link. 
 Click the Delimited option button. 
 Click Next. 
 Click the Tab option button. 
 Check the First Row Contains Field Names check box: 

 

 
 

 Click Next. 
 Select the TerritoryID column. 
 From the Data Type drop-down menu, select Long Integer: 
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 Select the TerritoryDescription column. 
 From the Data Type drop-down menu, select Text: 

 

 
 
 Scroll to the right and select the RegionID column. 
 From the Data Type drop-down menu, select Integer. 
 Click Next. 
 Name the linked table Territories. 
 Click Finish. 
 Click OK on the confirmation pop-up dialog box. 
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Importing Data into Access 
 

 Click Tables in the Objects pane. 
 Click the New button. 
 Select Import Table. 
 Click OK. 
 This opens the Import dialog box. 
 From the Files of type drop-down menu, select Text Files (*.txt; *.csv; 

*.tab; *.asc). 
 Locate your Access XP Intermediate Samples folder. 
 Select the EmployeeTerritories.txt file. 
 Click Import. 
 Click the Delimited option button. 
 Click Next. 
 Click the Tab option button. 
 Check the First Row Contains Field Names check box. 
 Click Next. 
 Click the In a New Table option button: 

 

 
 

 Click Next. 
 Accept the defaults and click Next. 
 Select the No primary key option button: 

 

SAMPLE



Microsoft Access XP - Intermediate Level Workbook - Page 29 

FOR USE AT THE LICENSED SITE(S) ONLY  
 Cheltenham Courseware Ltd. 1995-2010 www.cheltenhamcourseware.com 

 
 

 Click Next. 
 Name the new imported table EmployeeTerritories. 
 Click Finish. 
 Click OK on the confirmation pop-up dialog box. 
 
 

Exporting Data from Access 
 

 Click Tables in the Objects pane. 
 Select the Products table. 
 From the main menu, select File > Export. 
 Locate your Access XP Intermediate Samples folder. 
 Type Products for the File name. 
 From the Save as type drop-down menu, select Text Files (*.txt; *.csv; 

*.tab; *.asc). 
 Click Export. 
 Click the Delimited option button. 
 Click Next. 
 Click the Tab option button. 
 Check the First Row Contains Field Names check box. 
 Click Next. 
 Click Finish. 
 Click OK. 
 
 

SAMPLE
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Building Expressions 
 
 

Using the Expression Builder 
 

 Click Queries in the Objects pane. 
 Open the UnitPrice * 10 query in Design view. 
 Click in a blank field on the query grid. 
 Click the Build button on the Query Design toolbar: 

 

 
 

 In the Expression Builder, double-click the Functions folder. 
 Click Built-In Functions. 
 Click Text. 
 Double-click the Left function to add it to the expression builder pane: 

 

 
 

 Replace «stringexpr» with [ProductName]. 
 Replace «n» with 1: 

 SAMPLE
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 Click OK. 
 Rename the column from Expr2 to Rolodex. 
 Change the sort order to Ascending: 

 

 
 

 Run the query. 
 Save the changes. 
 Close the UnitPrice * 10 query. 
 
 

Using Common Built-in Functions 
 

 Click Reports in the Objects pane. 
 Open the Categories and Products report in Design view. 
 Click the Text Box button on the Toolbox toolbar. 
 Add a Text Box control to the Page Footer section of the report. 
 Label the new control DATE: 

 

 
 

 Double-click on the unbound portion of the DATE control. 
 Click the Data tab. 
 Click the ellipses next to the Control Source field: 
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 Double-click Functions. 
 Click Built-In Functions. 
 Click Date/Time. 
 Double-click Date to add it to the control: 

 

 
 

 Click OK. 
 Save the changes to the Categories and Products report. 
 Close the report. 
 Exit Microsoft Access 2002. 
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